Учебная работа № /7251. «Контрольная Численные методы, вариант 10

Учебная работа № /7251. «Контрольная Численные методы, вариант 10

Количество страниц учебной работы: 5
Содержание:
1. С точностью до 0,0005 вычислить все корни уравнения:
а) ,
б)
2. Приняв N=20, вычислить интеграл

Оценить погрешность результата по правилу Рунге (методом двойного счёта).

Стоимость данной учебной работы: 585 руб.Учебная работа № /7251.  "Контрольная Численные методы, вариант 10

Укажите Ваш e-mail (обязательно)! ПРОВЕРЯЙТЕ пожалуйста правильность написания своего адреса!

Укажите № работы и вариант


Соглашение * (обязательно) Федеральный закон ФЗ-152 от 07.02.2017 N 13-ФЗ
Я ознакомился с Пользовательским соглашением и даю согласие на обработку своих персональных данных.


Введите символы с изображения:

captcha

Выдержка из похожей работы


ПОСЛЕДОВАТЕЛЬНОСТЬ РЕШЕНИЯ ЗАДАЧИ 1
1, По заданным экспериментальным данным построить методом наименьших квадратов аппроксимирующую зависимость ,
2, Построить график функции g(x) с нанесенными на нем точками экспериментальных данных,
3, Построить график функции F(g(x),x) на интервале [a, b] с шагом (b-a)/20,
4, Вычислить интеграл методом средних прямоугольников для 20 разбиений и методом трапеций для 10 и 20 разбиений, По значениям, полученным методом трапеций, получить уточнение интеграла по методу Ричардсона и считать его решением всей задачи,
5, Считая значение, полученное методом Ричардсона, точным, определить погрешности значений, полученных методами средних прямоугольников и трапеций,
Исходные данные

x

2,00

2,00

2,00

2,40

2,80

2,80

3,20

3,20

3,60

4,00

g(x)

1,544

1,171

0,911

1,544

0,588

0,540

1,021

0,580

0,789

0,740

4,40

4,40

4,40

4,80

4,80

5,20

5,20

5,20

5,60

6,00

1,071

1,100

0,727

0,677

0,348

0,579

0,478

0,746

0,592

0,725

Аналитический вид функции
РЕШЕНИЕ
1, Строим аппроксимирующую зависимость методом наименьших квадратов,
Последовательность действий при аппроксимации экспоненциальной зависимостью выглядит так:
— вычисление логарифмов значений аппроксимируемой функции
— вычисление коэффициентов а и b по формулам ;
— вычисление коэффициентов с и d по формулам и ;
— вычисление значений g(x) по формуле ,
Решаем эту задачу табличным способом в электронных таблицах Excel,
Задание 1,1
При составлении расчетной таблицы был использован метод лианеризации, При этом обе части аппроксимируемой зависимости были подвергнуты процедуре логарифмирования,
Теперь рассчитываем коэффициенты уравнения по формулам:
Поэтому в соответствующие столбцы вводим формулы:
=A3^2 — для определения квадрата значения х,
=LN(B3) — для определения логарифма функции g(х),
=A3*D3 — для определения ,
=СРЗНАЧ(A3:A22) — среднее значение х,
=СРЗНАЧ(B3:B22) — среднее значение g(х),
=СРЗНАЧ(D3:D22) — среднее значение логарифма функции g(х),
Теперь можно посчитать по соответствующей формуле d,
=(A24*D24-E24)/(A24^2-C24)
А затем определить значение с: =EXP(D24-E26*A24),
Аналитический вид функции g(х) имеет вид ,
Теперь подсчитываем эмпирический ряд значений функции g(х) и вектор ошибок, возведенных в квадрат =(F3-B3)^2,
2, Строим график функции g(x) с нанесенными на нем точками экспериментальных данных,

3″